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Introduction

MEGS_Log is a Windows-based graphics application designed for use by exploration and mine 
geologists.  It has been created to allow rapid manipulation and interpretation for correction of 
bore logs with associated downhole geophysical LAS data.  Its main features include:

Interactive Borehole Visualisation

Bitmapped graphics and Window-based scrolling allow the user to scroll rapidly up and down a 
borehole.  The application allows viewing of two boreholes side by side.  You can change the 
scale of the bores, scroll up and down to align seams at different depths, or jump to a user-
defined depth in the bores.

Interactive Geophysics Visualisation

MEGS_Log allows you to select multiple LAS files simultaneously.  The LAS files may 
contain different tools and may have different sampling increments.  Trace display attributes 
such as colour, scale, screen location, etc can be set up within a Windows dialog box. 
Alternatively, user-defined templates allow all attributes to be pre-specified, permitting 
expeditious loading and display of data.

Borehole data and geophysical data may be scrolled simultaneously.  The origin of selected 
geophysical traces may be offset to correct for such errors as the inaccurate starting point of a 
geophysical tool.

Interactive Borehole Editing

Tools supplied with MEGS_Log allow you to adjust boreholes using a graphical interface.  You 
can change the appearance of the graphic log by such functions as Delete a Unit, Insert a Unit,  
Set the Rock Type, Shift a Rock Boundary, etc.

Boreholes can be edited in Overwrite Mode or Insert Mode.  These modes are used primarily to 
specify how a logged unit behaves when its base depth is dragged graphically.  By dragging a 
unit downwards in Insert Mode, you are effectively increasing the thickness of that unit.  As a 
result, all of the base depths of the units below will be automatically adjusted.  Overwrite Mode 
adjusts only the thickness and base depth of the units above and below the dragged boundary.

All edits/corrections made in MEGS_Log are saved back to the original borehole data file to 
create a completely adjusted log.  Other data that has been collected for the hole, for example, 
colour, grain size, weathering information etc., are retained in the original data file.  An 
exception to this is, of course, if a unit is deleted, all data for that unit is removed from the 
original data file.

Seam Correlation and Sample Numbering

MEGS_Log allows the user to define Seam Correlations for a loaded borehole.  The 
correlations are initially set up in a table from which the user can select a correlation to apply. 

2



Once applied, the correlations are displayed alongside the borehole.  You may allocate sample 
numbers to intervals/plies of each seam using the Sample Numbers View mode.

The Menus

The menus are listed on the menu bar at the top of the MEGS_Log screen.

Below, each menu has been opened and the list of commands displayed:
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Getting Started in MEGS_Log

Note that all clicks are made with the left button unless otherwise stated.

Loading Up

1. Make a new bore log:

To make a new borehole, select New from the File menu.  A dialog box will appear, prompting 
you to select the right or left borehole as the new hole.  The new borehole should be created on 
the RH column to ensure its alignment with the LAS traces.  To make either column active you 
can just click on the column you want active, and its name at the top of the column will appear 
magenta in colour.

The Project Details can also be set from the File menu.  A window appears asking for the Site 
Name to be entered, which is used for printing sample labels later on.

2. Or load a started borehole:

A started borehole can be loaded by selecting Load Boreholes or Open from the File menu.

This produces a dialog box listing all borehole files under their directories.  Simply select the 
desired file by double clicking on it, or by one click and then OK, and the file will be loaded.

3. Load the LAS data:

(a) From the Traces menu, click on Select LAS Files.  A window similar to the one shown 
above will appear.  Select the correct directory path from the pull-down box and the list of 
LAS files will appear.

(b) Ctrl-Click or Shift-Click to highlight all the traces to load, then click on OK.  The LAS 
traces will now appear on the screen.  If the traces are excessively “noisy”, they can be 
filtered using the View – Filter Traces option.

(c) Select Curve Setup/Load from the Traces menu.  This presents a window where trace 
attributes such as scale and colour can be modified.  The appearance of traces from different 
LAS files can be selected by the pull down box at the top of the window.

4. Adjusting a misaligned trace:
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If the traces are misaligned, click on the trace to be shifted, it will appear bold.  From the Traces 
menu, select Shift Trace, a window will prompt for the distance by which the trace should be 
moved.  Positive values move the trace downwards; negative values shift it upwards.

Usually a trace need only be shifted by an increment of about 0.02m.  Try this initially, and 
increase the increment as necessary.  The amounts entered are not cumulative; hence you would 
enter 0.02, then 0.04, etc.  Trace shifts are not saved back to the data file, so if you reload the 
LAS at a later date, you will need to realign the traces.

Borehole Interpretation

You are now ready to interpret or modify the borehole.  Some of the functions for which 
MEGS_Log is commonly used are listed below, and the way you use this program will depend 
on what kind of function you wish to perform.

1. Cored logged holes:  modification using LAS traces.
2. Open holes:  user interpretation from LAS data with the aid of field logs.
3. Old boreholes:  entry of data from old logs to generate graphics for correlation purposes.

1) Cored logged holes:  modification using LAS traces

A complete logged borehole graphic will have been imported into the RH column (see 
“Loading Up” 1 & 2, pg 4).  In this situation, MEGS_Log is used to adjust lithological 
boundaries to coincide with the LAS data, correcting errors made through core loss and 
measuring, and providing an opportunity to interpret the rock types of lost core.

i. From the Options menu, select Settings All and then the Insert Mode button. In this mode, 
dragging a boundary changes the thickness of the unit above it, and automatically readjusts 
all boundaries below it, hence adjusting for core loss as you progress down the column. 
(Use this mode with some caution).

ii. Other useful Options settings are:
• Scale.  The default scale is 1:200, and can be changed as desired by setting the new scale 

in the dialog box.
• Ruler.  Clicking on this option produces a horizontal line which moves across the traces 

in unison with the cursor to aid in setting accurate stratigraphic boundaries.

Use items from the Tools menu to alter boundaries and rock types.  The function keys provide a 
quicker alternative to picking from the menu.  An Undo function is located under the Edit menu 
(short-cut Ctrl+Z), and can undo up to 10 edits.
 
To create a boundary, select Create Boundaries from the menu, or press F2.  When the cursor 
is positioned in the column, a hammer icon and crosshairs appear.  Position the centre of the 
crosshairs where you pick the boundary to be, and click.

To drag a boundary, select Pick and Drag or press F3.  An arrow icon will appear.  Position 
the arrow above the boundary to be moved, and click.  The boundary will turn red and a handle 
will appear at the RH side.  Position the point of the arrow on the handle, click and drag.
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To eliminate a boundary, select Merge or press F5.  Position the crosshairs below the 
boundary to be deleted and click.  A dialog box will appear to confirm the merge, after which, if 
Yes is selected, the rock type of the lower unit will merge upwards to replace that which was 
above the deleted boundary.

To set a boundary base depth, select Set Base Depth or press F7.  Click within the unit for 
which the basal boundary is to be moved.  A dialog box will appear with the existing boundary 
depth.  Edit this depth as desired, and click OK.

To nominate or change a rock type, select Set Rock or press F4.  A magnifying glass icon 
containing crosshairs appears.  Click in the selected area of the column, which will bring up a 
Rock Type menu as shown below:

(a) For a single rock type, click on the pull-down arrow on the LH side.  This produces a 
rock type list in alphabetic order.  Scroll through or short-cut by pressing the initial letter 
of the desired rock type (e.g. ‘s’ for sandstone).  Click on the selected name, then on OK 
or hit the Enter key.  The allocated pattern for that rock type will appear in the borehole 
display column.

(b) For a combination of rock types (e.g. 70% siltstone, 30% mudstone), select the first rock 
type from the LH box and change its percentage from 100 to the desired value.  Select the 
second rock type from the RH box in the same way, and the program will already have 
calculated its corresponding percentage.  Hit OK, or Enter.

2) Open holes:  user interpretation from LAS data with the aid of field logs

Interpretation from LAS data is possible only below the standing water level in the borehole. 
Traces above this level will appear abnormal, usually as straight lines.

From the Options menu, select Settings All and then the Overwrite Mode button.  In this mode, 
dragging a boundary will have no effect on boundaries above or below it.

To set boundaries and rock types, see section 1. on page 5.
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To insert a unit, select Insert or press F6.  Click in the unit in which a new record is to be 
inserted.  A dialog box will appear like the one below:

The mode, Insert or Overwrite, can be selected from this box to temporarily allow an over-ride 
to the default setting under Options Settings All.  The unit placement determines where the 
record will be inserted:

a) If above is chosen, the record will be inserted above the top of the unit that was originally 
clicked in.

b) If below is chosen, the record will be inserted below the base of the unit that was 
originally clicked in.

c) If nominate is chosen, the record will be inserted at exactly the depth nominated (i.e. the 
top of the unit inserted will occur at the depth entered).  This depth must be within the 
range of the unit originally clicked in.

Choose the rock type(s) of the unit to be inserted, and enter the thickness of the record to be 
inserted.  The default thickness is 0.2m.  Click OK, or hit Enter and the new unit will appear as 
specified.

To delete a unit, select Delete or press F10.  Click in the unit to be deleted and click Yes in the 
box that pops up to confirm the delete of the selected unit.  All records below the unit deleted 
will then be shifted up the hole, regardless of the mode set (Insert or Overwrite).

3) Old boreholes:  entry of data from old logs to generate graphics for correlation 
purposes

When only paper copies of geophysical logs are available, obvious lithological boundaries need 
to be hand-picked and entered in the stratigraphic column using the Create Boundaries tool 
(short-cut key F2).

A useful aid in this situation is the depth indication figure which appears at the bottom of the 
screen, below the borehole column.  Simply run the cursor down the column until the depth 
indication figure reaches the desired value, and click to create the boundary.  When using the 
depth indication figure, the Depth Tolerance can be set from the Options Settings All menu. 
This allows boundaries to be created or moved to the nearest 0.005m, 0.01m, 0.02m etc, as 
desired.
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Once all possible boundaries have been established from the geophysical logs, remaining data 
such as rock types, can be entered from field logs or other available data (see section 1. on page 
5).

Correlation and Sample Numbers

For correlation of bores in MEGS_Log, a customized menu listing of the stratigraphic units in 
your area of exploration can be created, enabling units to be labeled down the RH side of the 
display column.  To create your list of seam names, see “Customizing MEGS_Log” on page 10.

Correlating in MEGS_Log:

1. To aid in correlation, a previously processed borehole can be loaded into the LH display 
column.  Select the appropriate borehole file from the Open or Load options in the File 
menu.

2. The RH scroll bar moves both columns and traces while maintaining their alignment. 
The scroll bar between the two display columns moves the LH column only.  To move 
in single increments, click on the up and down arrows.  For larger shifts, click inside the 
bar near the arrows, pick and drag the handle along the bar, or simply scroll with the 
mouse wheel.

3. Fine Scroll, from the Options menu (or short-cut Ctrl+F), allows the user to move both 
columns together, or the LH column only, in finer increments for precise alignment of 
the two bores.

4. Using Scale, from the Options menu, boreholes can be compressed to compare entire 
bores on the screen for initial gross correlation, or blown up for detailed picks.

5. When first selecting the Correlate tool (F8) from the Correlate menu, MEGS_Log will 
prompt you to Select Site.  Scroll through the names in the display box to select the 
correct site.

6. To label a single rock unit, press F8 or select the Correlate tool, place the crosshairs 
within the unit and click.  A “Correlate” box will appear.  By scrolling through the list, 
select the desired seam name, and click on OK or hit the Enter key.

7. To apply the seam name to a sequence of units, place the crosshairs within the top unit 
and click and drag a box to within the lowest unit.  The “Correlate” dialog box will 
appear, select the desired seam name, click OK or Enter.  The chosen units will be 
assigned the seam name, labeled at the roof and floor of the sequence.

Sample number allocation:

1. Selecting Sample Numbers from the View menu toggles between displaying sample 
numbers and seam names against the RH side of the borehole.  By activating the 
Correlate tool (F8) with the sample numbers displayed, numbers can be assigned to 
single or multiple units in the same way as seam codes.  Sample numbers may be alpha-
numeric, and up to 10 characters in length.
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2. When correlation and the allocation of sample numbers is complete, sample tags can be 
printed by selecting Print Labels under the File menu.  A “Print” window appears, in 
which you can specify to which printer the labels should be sent.

3. Print Preview under the File menu shows the layout of the sample labels to be sent to 
the printer.  This preview should be used as an example only, as it may not show the 
exact data that will be printed on the tags.

Useful User Tip:

By right-clicking on any unit within the borehole column, a window is opened that contains all 
the information for that unit, i.e. rock types, seam name, unit top and base depths, and the 
sample number.  The Previous and Next buttons show the information for the units 
progressively up or down the hole, highlighting in green the unit for which the information is 
displayed.
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Customizing MEGS_Log

The Setup menu allows the User to change the way the rock types and traces are displayed, as 
well as set up the seam correlations for different sites.

Seam names for correlation

To create your list of seam names, from the Setup menu, select 
Correlations.  Edit the text file that opens (as at left) by putting your site 
name in inverted commas as a new line in the Section Correlations part 
of the file, under the Table Sites.  Then, at the bottom of the file, on a 
new line, insert a # and then enter a new Section “Your site name,” and 
then list your seam codes under Table Seams, in stratigraphic order 
down-hole.  Finish off by End Table and then End Section.  Save and 
close the text file, and the new site and seam labels will be available 
within the program for correlations.

Geophysical trace displays

To change the default settings for the scale or appearance of your LAS 
data, edit the text file that opens from the Setup Trace Defaults menu.

You will need to know the name of the curve in your LAS data that 
you want to change the trace display/scale for.  The file is in free 
format and controls the following (in order, on each line).
Curve name
Minimum X axis value
Maximum X axis value
Trace display colour
Column number to display the trace on (numbered from left to right 
across the screen)
The axis to represent the curve value on (always Y).

Rock types and hatch patterns

If MEGS_Log does not recognize a rock type, the unit will be displayed blank, with red bars 
down the sides.  To fix this, or to change which predefined hatch pattern is assigned to each 
rock type, edit the comma delimited file that opens when you choose Setup Rock types.  Make 
sure you spell the rock type exactly as it is in your original bore log, but it’s not case sensitive. 
You can have up to ten rock types matched to a particular bitmap pattern.  Do not change the 
order of lines in this file (i.e. insert or delete rows), as they are mapped directly to their patterns 
within the program.  When you’ve made your rock type edits, save the file (still in the comma 
delimited format) and the program will display the newly matched pattern for your rock type.
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MEGS_Log uses both Vector and Bitmap patterns to display different rock type hatches. 
Vector patterns are generally used to display the various categories of coal, which are 
represented in the graphics by some combination of horizontal lines that stretch vertically to fill 
the space allocated to them.  These vector patterns are currently not customizable in 
MEGS_Log.

The majority of the hatch patterns in MEGS_Log are controlled by Bitmaps which use a pattern 
designed within a square, which is then repeated over the area designated to that particular 
lithology.  The unit square is very small, and is divided into an 8 x 8 grid, giving 64 spaces 
which can either be filled or left blank to compose the symbol.  The spaces in the grid are 
named using hex-decimal. 

The 8 x 8 grid is divided into 16 rectangles, each of 4 horizontally-aligned spaces (see above). 
The unit therefore comprises 8 lines, each line being composed of 2 rectangles.

Every space which is left blank is designated by a 1, and every filled space is designated by a 0. 
The LH column on the right lists all the combinations of filled or blank spaces possible within 
one rectangle of 4 spaces.  For simplification purposes, we represent each permutation by a 
single digit or letter, as listed in the RH column. 

Above is the plot for the Claystone symbol.  Offsets and overlap must be designed for 
continuity of the pattern as it is repeated.  Each of the 8 lines of the unit has been reduced to 2 
characters, representing its left and right hand sides.

To change the Bitmap patterns in MEGS_Log, select Setup Bitmaps and edit those already set 
up (keeping them in the same format, you need a “0” and a lower case “x” before each line 
pair).  The facility to add more bitmap patterns to this file is currently not available in 
MEGS_Log.
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